Jump to content
Mumble forums

PPA Mumble on Raspbian/Raspberry PI OS (Buster) uses outdated version


Recommended Posts

Hello,

 

I've noticed that my mumble server on my Raspberry Pi2b which runs Raspbian Buster(headless server), is using version 1.3.0 of the murmur software. Which was released in september 2019. The program runs flawlessly (Thanks! :) ), but i'm a bit concerned about the missing security fixes of the newer builds. So i tried to update the program.

 

I have installed mumble server via 'apt' from the supplied Raspbian repository. But the problem is, i cannot upgrade it to version 1.3.4. Version 1.3.0 is the latest the repository provides.

I cannot find a (release) PPA that supports Raspbian. I tried adding the Ubuntu/Debian release PPA, but that obviously didn't work (x86 vs ARM).

 

I have two questions:

 

Are build numbers for the client and server software the same?

 

If the answer is yes, where can i find a PPA that supports Raspbian and ARM devices so i can keep updating to the latest build? For example, who build the working mumble-server 1.3.0 arm port? And why isn't it updated anymore?

 

Thanks for your help

 

 

Link to post
Share on other sites
  • Administrators
17 hours ago, Dreknek said:

Are build numbers for the client and server software the same?

Yes

 

17 hours ago, Dreknek said:

If the answer is yes, where can i find a PPA that supports Raspbian and ARM devices so i can keep updating to the latest build? For example, who build the working mumble-server 1.3.0 arm port? And why isn't it updated anymore?

I think we don't have an official Raspbian PPA.

The ARM build available in the repositories was probably be built by one of the repo maintainers. I guess you should try to contact them...

 

Another option would be to compile Mumble yourself. Given that there is a package in the repo for it, I assume chances are good that the dependencies needed for that are in the repo as well. You can find the build instructions at https://github.com/mumble-voip/mumble/blob/master/docs/dev/build-instructions/README.md

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...