Jump to content
Mumble forums

Overlay problem


Recommended Posts

I use debian testing operating system - kernel 2.6.39-bpo.2-686-pae. Mumble version 1.2.3-2+b2. Now some logs:

 

morfik:~$ mumble
QSslSocket: cannot resolve SSLv2_client_method
QSslSocket: cannot resolve SSLv2_server_method
G15LCDEngineUnix: Unable to connect to G15Daemon.
CELT bitstream 8000000b from libcelt0.so.0.0.0
Locale is pl_PL
Database SQLite: "3.7.7" 
*** WARNING *** The program 'mumble' uses the Apple Bonjour compatibility layer of Avahi.
*** WARNING *** Please fix your application to use the native API of Avahi!
*** WARNING *** For more information see <http://0pointer.de/avahi-compat?s=libdns_sd&e=mumble>
Overlay: Removing old socket on "/home/morfik/.MumbleOverlayPipe" 
Overlay: Listening on "/home/morfik/.MumbleOverlayPipe" 
GlobalShortcutX: Unable to open any keyboard input devices under /dev/input, falling back to XInput
GlobalShortcutX: Using XInput 2.0
GlobalShortcutX: XInput 4:Virtual core XTEST pointer
GlobalShortcutX: XInput 5:Virtual core XTEST keyboard
GlobalShortcutX: XInput 6:Power Button
GlobalShortcutX: XInput 7:Power Button
GlobalShortcutX: XInput 8:Logitech Logitech USB Keyboard
GlobalShortcutX: XInput 9:Logitech Logitech USB Keyboard
GlobalShortcutX: XInput 10:A4Tech USB Mouse
SocketRPC: Removing old socket on "/home/morfik/.MumbleSocket" 
AudioInput: 72000 bits/s, 48000 hz, 480 sample CELT
PulseAudio: Starting input alsa_input.pci-0000_03_00.0.analog-stereo
PulseAudio: Starting echo: alsa_output.pci-0000_03_00.0.analog-surround-40.monitor
PulseAudio: Starting output: alsa_output.pci-0000_03_00.0.analog-surround-40
AudioInput: Initialized mixer for 1 channel 48000 hz mic and 0 channel 48000 hz echo
warning: The VAD has been replaced by a hack pending a complete rewrite
AudioOutput: Initialized 4 channel 48000 hz mixer
AudioInput: Initialized mixer for 1 channel 48000 hz mic and 1 channel 48000 hz echo
warning: The VAD has been replaced by a hack pending a complete rewrite
AudioInput: ECHO CANCELLER ACTIVE
OpenSSL Support: 1 (OpenSSL 1.0.0e 6 Sep 2011)
SSL: Adding recommended CA UTN-USERFirst-Client Authentication and Email

 

Now I start the game with mumble-overlay. Its world of warcraft on WINE:

 

mumble-overlay wine Wow.exe

 

Game is starting and i see this:


http://img849.imageshack.us/img849/816/20111022205651.png


Additionally, when i minimized the game window, i got this error in mumble console:

 

"Text "Hatecrime" did not fit (+2/-0): (+0.71875/-0.015625). Scaling to 3.49246e-09." 
"Text "Hatecrime" did not fit (+2/-0): (+0.71875/-0.015625). Scaling to 8.13152e-19." 
QPainter::begin: Paint device returned engine == 0, type: 2
QPainter::setRenderHint: Painter must be active to set rendering hints
QPainter::setRenderHint: Painter must be active to set rendering hints
QPainter::setBackground: Painter not active
QPainter::setCompositionMode: Painter not active
QPainter::setBrush: Painter not active
QPainter::setPen: Painter not active
QPainter::drawPath: Painter not active
QPainter::setPen: Painter not active
QPainter::drawPath: Painter not active
"Text "Hatecrime" did not fit (+2/-0): (+0.71875/-0.015625). Scaling to 1.89327e-28." 
QPainter::begin: Paint device returned engine == 0, type: 2
QPainter::setRenderHint: Painter must be active to set rendering hints
QPainter::setRenderHint: Painter must be active to set rendering hints
QPainter::setBackground: Painter not active
QPainter::setCompositionMode: Painter not active
QPainter::setBrush: Painter not active
QPainter::setPen: Painter not active
QPainter::drawPath: Painter not active
QPainter::setPen: Painter not active
QPainter::drawPath: Painter not active
"Text "Hatecrime" did not fit (+2/-0): (+0.71875/-0.015625). Scaling to 4.4081e-38." 
QPainter::begin: Paint device returned engine == 0, type: 2
QPainter::setRenderHint: Painter must be active to set rendering hints
QPainter::setRenderHint: Painter must be active to set rendering hints
QPainter::setBackground: Painter not active
QPainter::setCompositionMode: Painter not active
QPainter::setBrush: Painter not active
QPainter::setPen: Painter not active
QPainter::drawPath: Painter not active
QPainter::setPen: Painter not active
QPainter::drawPath: Painter not active
The application (or it's libraries) caught a Segmentation Fault. Backtrace follows:
Backtrace: /usr/lib/libg15daemon_client.so.1(+0xb3b) [0xb7618b3b]
Backtrace: [0xb773d400]
Backtrace: /usr/lib/libQtGui.so.4(_ZNK14QX11PixmapData20takeQImageFromXImageERK14QXImageWrapper+0x6e) [0xb6701c6e]
Backtrace: /usr/lib/libQtGui.so.4(_ZNK14QX11PixmapData7toImageERK5QRect+0x138) [0xb6702d48]
Backtrace: /usr/lib/libQtGui.so.4(_ZNK14QX11PixmapData7toImageEv+0x4d) [0xb670039d]
Backtrace: /usr/lib/libQtGui.so.4(_ZNK7QPixmap7toImageEv+0x3d) [0xb66ec91d]
Backtrace: /usr/lib/libQtGui.so.4(+0x358980) [0xb67f9980]
Backtrace: /usr/lib/libQtGui.so.4(_ZN8QPainter10drawPixmapERK7QPointFRK7QPixmap+0x74) [0xb676ef24]
Backtrace: /usr/lib/libQtGui.so.4(_ZN19QGraphicsPixmapItem5paintEP8QPainterPK24QStyleOptionGraphicsItemP7QWidget+0x6d) [0xb6c5ad0d]
Backtrace: /usr/lib/libQtGui.so.4(+0x7fdfa7) [0xb6c9efa7]
Backtrace: /usr/lib/libQtGui.so.4(+0x7fea9e) [0xb6c9fa9e]
Backtrace: /usr/lib/libQtGui.so.4(+0x7fdbf7) [0xb6c9ebf7]
Backtrace: /usr/lib/libQtGui.so.4(+0x7fea9e) [0xb6c9fa9e]
Backtrace: /usr/lib/libQtGui.so.4(+0x7fdbf7) [0xb6c9ebf7]
Backtrace: /usr/lib/libQtGui.so.4(+0x7fea9e) [0xb6c9fa9e]
Backtrace: /usr/lib/libQtGui.so.4(_ZN14QGraphicsScene9drawItemsEP8QPainteriPP13QGraphicsItemPK24QStyleOptionGraphicsItemP7QWidget+0x215) [0xb6ca0095]
Backtrace: /usr/lib/libQtGui.so.4(_ZN14QGraphicsScene6renderEP8QPainterRK6QRectFS4_N2Qt15AspectRatioModeE+0x786) [0xb6c88a06]
Backtrace: mumble() [0x8178ae6]
Backtrace: mumble() [0x820b4f8]
Backtrace: /usr/lib/libQtCore.so.4(_ZN11QMetaObject8metacallEP7QObjectNS_4CallEiPPv+0x3d) [0xb6231e4d]
Backtrace: /usr/lib/libQtCore.so.4(_ZN14QMetaCallEvent13placeMetaCallEP7QObject+0x35) [0xb623c795]
Backtrace: /usr/lib/libQtCore.so.4(_ZN7QObject5eventEP6QEvent+0x26f) [0xb6243caf]
Backtrace: /usr/lib/libQtGui.so.4(_ZN19QApplicationPrivate13notify_helperEP7QObjectP6QEvent+0xc4) [0xb66050a4]
Backtrace: /usr/lib/libQtGui.so.4(_ZN12QApplication6notifyEP7QObjectP6QEvent+0x172) [0xb660a432]
Backtrace: /usr/lib/libQtCore.so.4(_ZN16QCoreApplication14notifyInternalEP7QObjectP6QEvent+0x8e) [0xb622ba9e]
Backtrace: /usr/lib/libQtCore.so.4(_ZN23QCoreApplicationPrivate16sendPostedEventsEP7QObjectiP11QThreadData+0x2f4) [0xb622f264]
Backtrace: /usr/lib/libQtCore.so.4(_ZN16QCoreApplication16sendPostedEventsEP7QObjecti+0x2c) [0xb622f3ac]
Backtrace: /usr/lib/libQtCore.so.4(+0x19a894) [0xb6259894]
Backtrace: /lib/libglib-2.0.so.0(g_main_context_dispatch+0x1d2) [0xb5d7c252]
Backtrace: /lib/libglib-2.0.so.0(+0x43a30) [0xb5d7ca30]
Backtrace: /lib/libglib-2.0.so.0(g_main_context_iteration+0x64) [0xb5d7cce4]
Backtrace: /usr/lib/libQtCore.so.4(_ZN20QEventDispatcherGlib13processEventsE6QFlagsIN10QEventLoop17ProcessEventsFlagEE+0x67) [0xb6259cc7]
End of Backtrace.
mumble: pthread_mutex_lock.c:62: __pthread_mutex_lock: Warunek zapewnienia `mutex->__data.__owner == 0' nie został spełniony.
Przerwane

 

How fix the display fonts on game window?


In preview it looks good:

http://img21.imageshack.us/img21/1746/20111024002544.png


But when I disable "show FPS" all things from overlay dissapear from the main game window.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...